
To view a catalog of movies, double-click the catalog’s icon on the desktop. You can also 
open movies or catalog files directly. using the “Open” command in the “File” menu.

The catalog window displays a set of movie posters. To play a movie, double-click its image. 
A full-screen window will open with the movie in it, centered on a gray background. The 
movie will automatically begin to play. When the movie finishes, the window will close 
automatically.

Single clicking on the movie image will stop playback. Double clicking will restart it. You can 
also start and stop by pressing the space bar. You can step through the movie one frame at a
time by using the left and right arrow keys. The up and down arrow keys control the volume. 
Hold down the Shift while you double click on the movie and it will play backward!

A movie controller appears along the bottom edge of the movie window. Press on the 
speaker icon and drag to control the volume. Next to that is a play/pause button you can 
click. Next to that is the play bar. You can click or drag to position the movie to any frame. At
the right side of the controller are buttons which let you single step through the movie.

You can change the movie image size by using the commands in the “Window” menu. You 
can change the way movies play, and the way the movie window looks, by using the 
“Preferences” command in the “Edit” menu. You can also copy whole movies, movie 
segments, or single frames to the clipboard. You can also make your own catalogs and fill 
them with entries for all your movies. These activities are described below.

If you are using System 7.0 or higher, the Balloon Help menu appears at the right side of the
menu bar. Choose the “Show Balloons” command and then point to things to see 
descriptions of what they do.

If this text appears jagged to you, install the “Geneva 10” font into your system.

—————————————————

The File menu has commands to open catalogs and movies, to close windows, and to Quit 
the application.

The Open command shows a dialog box that can open catalog files and movie files. The 
“Show Preview” checkbox in the dialog opens up a preview area which shows a poster for 
movies you select, as a browsing aid.

The Close command will close the active (frontmost) window.

The Quit command will exit the application and return to the desktop.

—————————————————

The Edit menu has the usual commands to deal with the clipboard, plus a command to adapt
the application to your preferences.

The Undo, Cut and Paste commands are only active when desk accessories are used.

The Copy command can be used when a movie window is active. It will copy the selected 
part of the movie to the clipboard. To select a portion of the movie, use the “Select All” 



command, or the movie controller as described above. Both the movie segment and a 
picture of the first frame is copied, so if you paste into an application which doesn’t handle 
movies, you will still get a picture containing a movie frame.

To select a segment of the movie for copying, use the “Select All” command, or the movie 
controller in the movie window. Drag the controller’s play bar to the first part of your 
selection. Next, hold down Shift while you drag to the last part of the selection. The 
highlighted portion of the bar indicates the part of the movie that is selected. Another way 
to make a selection is to move to the start of the section, hold down Shift and type a Return. 
The movie plays until you release Shift, and the played portion of the movie will be selected.

The Clear command can be used when a catalog window is active. It will delete the selected 
movie from the catalog. This action can’t be undone, and the change is saved automatically.

The Preferences command opens a window which lets you control some aspects of the 
application’s operation.

The Always use the menu bar screen checkbox is only significant if your computer has more 
than one screen. Normally, EasyPlay will play movies and show some dialog boxes on the 
most colorful screen - the one which is set to the greatest color depth. If you turn this 
preference on, the main screen will always be used, even if it isn’t the most colorful.

The Don’t automatically play movies checkbox, if turned on, will not play movies when you 
open them. The movie will open, stopped at the first frame, and you have to double click on 
it (or use the space bar, return key or movie controller play button) to start it.

The Initially hide the movie controller checkbox, if turned on, will cause movie windows to be
opened without the movie controller. You can make the controller appear yourself by using 
the “Show Controller” command in the “Movie” menu.

The Don’t close movies when finished checkbox, if turned on, will leave the movie window 
open when it is finished playing. You can close the movie window yourself with the “Close” 
command in the “File” menu, or the window’s close box.

The Show the Catalog menu checkbox, when turned on, will make a “Catalog” menu appear 
in the menu bar. It contains commands that let you create your own catalog files for use with
EasyPlay. If you just want to play movies, this menu isn’t needed.

The Background popup menu lets you control the color, and presence, of the background in 
movie windows.

The Black, Gray, and White background choices control the background color.

The None background choice says to use no background. The movie will open in a window 
that is the same size as the movie image, instead of in a full-screen window.

The Default size popup menu controls the size at which the movie is originally opened. You 
can change the size later using commands in the “Window” menu. The “Normal” size is the 
most efficient, and is the size at which the movie was recorded.

—————————————————

The Movie menu is active when a movie window is active. It contains commands to control 



some aspects of movie playback.

The Loop command will cause the movie to play in a loop, over and over until you stop it. 
Some movies are meant to loop, especially if they are very short.

The Loop Back and Forth command will cause the movie to play forward at first, but when it 
reaches the end, it will play backward to the beginning. It will keep reversing directions until 
you stop it.

The Play Selection Only command will restrict playback (or looping) to the selected part of 
the movie. See description of the Copy command for instructions on selecting part of a 
movie.

The Show/Hide Controller command will alternately show and hide the controller bar in a 
movie window.

The Go to Poster Frame command will position a movie to its “poster”. When a movie is 
created, its creator chooses a representitive frame from the movie to be the poster which is 
shown in catalogs and previews.

—————————————————

The Window menu controls the size of movies, and lets you make a particular window active.

The Normal Size command will set the movie to its natural size, which gives the best 
playback. Half and Double sizes are relative to the normal size. Large size makes the movie 
the largest size that fits the window while maintaining the proper aspect ratio, and Full 
Screen will stretch the movie as needed to fit the screen. These last two sizes usually play 
very inefficiently.

At the end of the Window menu, the names of all the open windows appear. Selecting a 
name will cause that window to come to the front.

—————————————————

The Catalog menu only appears if the “Show the Catalog menu” checkbox in the 
“Preferences” command is turned on. It lets you create catalog files, and add entries to 
them.

A catalog file holds a list of entries. Each entry includes a title, description, and a movie 
“poster” picture. The entry does not include the movie itself, it merely has an internal 
pointer, or “alias” to the movie file. When you double click on an entry in the catalog 
window, EasyPlay looks for the movie and plays it. If it can’t find the movie, a dialog box will 
appear letting you locate it, and the catalog will remember the new location. A catalog file 
can hold a maximum of 4000 entries. 

A catalog file need not have access to its movies to be useful. For example, a catalog file 
could be made of all the movies on a bulletin board system. The movie descriptions could 
include the library and filename on the bulletin board, and the catalog could serve as a 
guide for downloading from the board. Or, you could make a catalog of movies on various 
diskettes and CD-ROMs that you own. When you double click an entry, EasyPlay will ask you 
to insert the proper item.



When you make changes to the catalog file, they are immediately written - thus, there is no 
“Save” command in EasyPlay. If you delete an entry with the “Clear” command, the space it 
took up in the catalog file is not recovered, but deleted entries do not count in the 4000 
entry limit.

If EasyPlay and the catalog file you are using are on a CD-ROM, you can get EasyPlay to 
draw the catalog much faster and find movies more quickly if you both the EasyPlay 
application and the catalog file from the CD-ROM to your hard disk. Of course, if the catalog 
file is on CD-ROM or a locked disk, it can not be modified. Copying it to the hard disk will let 
you make changes, if you like.

The New Catalog command will create a new, empty catalog file. A dialog box will appear 
where you name the file and choose its location. To open an existing catalog file, use the 
“Open” command in the “File” menu.

The Add an Entry command lets you add one catalog entry to the file which represents a 
movie. A dialog box appears which lets you choose the movie file. The new entry appears at 
the end of the catalog. The poster frame for the movie will appear as the entry’s picture. If 
no poster frame is defined in the movie, the first frame will be used. If there is no video in 
the movie (for example the movie contains audio only), a default “Now Playing” picture will 
appear. The movie file name will be used as the title, and the file location, size, length and 
characteristics will be used as the description. You can modify the title and description with 
the “Modify an Entry” command.

The Scan a Folder command is used to add a number of entries to the catalog at once. As 
with the “Add an Entry” command, a dialog box appears which lets you choose a movie file. 
Choose any file in the desired folder, and EasyPlay will add entries for all the movie files in 
that folder, and in any nested folders. It is possible to add a whole disk worth of movies to 
the catalog at once with this command.

The Modify an Entry command lets you make changes to the title and description of a 
catalog entry. First click on an entry in the catalog so it is highlighted with a thick border, 
then choose the “Modify an Entry” command. A short cut is to hold down the Option key 
while you double-click on an entry. A dialog box will appear letting you make changes. The 
maximum length of a title or description string is 255 characters. Although the default for 
the title is the file name, and the default description includes the file location, the texts can 
be anything you wish - EasyPlay keeps track of the file name and location independently and
internally.

The modify command lets you override some of the playback characteristics for the 
particular movie associated with an entry:

The Size popup menu allows you set the initial size of the movie image when it is opened. 
The “Use Preferences” setting causes the movie to open normally, using whatever 
preference the user has set in the “Preferences” command. The other settings cause the 
movie to open at half, normal, double, large or full size accordingly. The user can 
subsequently adjust the movie size with the commands in the “Window” menu.

The Depth popup menu allows you to cause the color depth of the screen to change when 
the movie opens, as though the user had used the Monitors control panel. Since changing 
the color depth of a screen is an unusual action which should always remain under user 
control, this command should be used sparingly. However, if a movie requires a particular 
depth, the command can be used. The “No Change” setting is normal - the depth won’t 
change when the movie is opened. The other settings will cause the depth to change. If the 



monitor does not support the desired depth, the “deepest” depth that it supports will be set.

The Play movie in a loop checkbox, if turned on, will cause the movie to initially open in a 
looping mode. The user can subsequently turn the looping off and back on by using the 
“Loop” command in the “Movie” menu.

The Sort by Order Added command will sort the entries in the catalog according to the order 
which they were added to the file. The catalog will retain whatever sort order you set.

The Sort by Title command will sort by whatever text is in the title (upper) string of each 
entry. 

The Sort by Description command will sort by whatever text is in the description (lower) 
string of each entry.

—————————————————

EasyPlay works best when used with System 7 or above, but it will work under System 6 as 
long as QuickTime™ is installed. In addition to the QuickTime system extension, you 
probably need to install 32-bit Color QuickDraw extension as well. Check with a dealer or 
software specialist to see how to install QuickTime on System 6. Under System 6, EasyPlay 
does not draw the text in “Pop up menus” such as those in the Preferences window, but 
when you pop them up you can see the selections and they will operate properly.

The EasyPlay application can be controlled by sending it high level events. An ‘aete’ internal 
resource describes the supported events. Some applications may be able to read this data to
determine the event specifications.

—————————————————

Important Notice
This EasyPlay™ application is copyrighted. It is not public domain, and it is not free. If you 
got a copy from a friend, a CD-ROM, a diskette, a bulletin board or other online service, or 
any other source, even if you paid for the media or software collection it was in:

If you find yourself using EasyPlay regularly, send the author $20.00 in U.S. funds.

If you obtained a “Toon-Time” CD-ROM disc by Leptonic Systems, a one-user payment is 
already included in the price of the disc. Have fun! You may give unchanged, unmodified 
copies to all your friends, post it on bulletin boards, or distribute copies of it in any other 
way. However, if any of the people who obtain such copies find themselves using EasyPlay 
regularly, they should send $20.00.

Others may place this software in a collection of publicly distributable software and sell it. 
Unfortunately, the author gets none of this money! I hope you got EasyPlay from a free or 
near-free source, but if you obtained EasyPlay in that way and find yourself using it 
regularly, you should still send $20.00.

This application is not copy protected in any way, doesn’t bother you with frequent 
reminders, and you have had a chance to try it first. You are trusted to do the right thing. If 
you use EasyPlay regularly, send the $20.00. Support the the hard work of the author!



Send a check drawn on a U.S. bank, or a money order in U.S. funds, to “Leptonic Systems 
Design Co.” at the address below. You may or may not receive a response, but please 
include your return address. The latest version of EasyPlay is posted by the author on the 
CompuServe Information Service.

Leptonic Systems Design Co.
717 E. Jericho Turnpike #321
Huntington Station NY 11746

CompuServe: 76004,1447
AppleLink: D4394

Have fun using EasyPlay!


